summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Marlow <marlowsd@gmail.com>2009-07-09 13:28:50 +0000
committerSimon Marlow <marlowsd@gmail.com>2009-07-09 13:28:50 +0000
commite55e7e8b6aae471d56cc7c77906d62d7ba07a2c1 (patch)
treeb2020a08ba02caac7dfd077e5c187ce08e6d9fa5 /configure.ac
parent011b3b8439402dd701093234fcca59bd38216206 (diff)
downloadhaskell-e55e7e8b6aae471d56cc7c77906d62d7ba07a2c1.tar.gz
workaround new Cygwin bash CRLF behaviour
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2d8fbe1311..f393dedd2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,7 +193,7 @@ if test "$build" = ""
then
if test "${WithGhc}" != ""
then
- build=`${WithGhc} +RTS --info | grep '^ ,("Target platform"' | sed -e 's/.*, "//' -e 's/")//'`
+ build=`${WithGhc} +RTS --info | grep '^ ,("Target platform"' | sed -e 's/.*, "//' -e 's/")//' | tr -d '\r'`
echo "Build platform inferred as: $build"
else
echo "Can't work out build platform"
@@ -205,7 +205,7 @@ if test "$host" = ""
then
if test "${WithGhc}" != ""
then
- host=`${WithGhc} +RTS --info | grep '^ ,("Target platform"' | sed -e 's/.*, "//' -e 's/")//'`
+ host=`${WithGhc} +RTS --info | grep '^ ,("Target platform"' | sed -e 's/.*, "//' -e 's/")//' | tr -d '\r'`
echo "Host platform inferred as: $host"
else
echo "Can't work out host platform"
@@ -217,7 +217,7 @@ if test "$target" = ""
then
if test "${WithGhc}" != ""
then
- target=`${WithGhc} +RTS --info | grep '^ ,("Target platform"' | sed -e 's/.*, "//' -e 's/")//'`
+ target=`${WithGhc} +RTS --info | grep '^ ,("Target platform"' | sed -e 's/.*, "//' -e 's/")//' | tr -d '\r'`
echo "Target platform inferred as: $target"
else
echo "Can't work out target platform"
@@ -274,7 +274,7 @@ checkOS() {
linux|freebsd|netbsd|openbsd|osf1|osf3|hpux|linuxaout|kfreebsdgnu|freebsd2|solaris2|cygwin32|mingw32|darwin|gnu|nextstep2|nextstep3|sunos4|ultrix|irix|aix)
;;
*)
- echo "Unknown OS $1"
+ echo "Unknown OS '$1'"
exit 1
;;
esac