summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRyan Scott <ryan.gl.scott@gmail.com>2020-03-25 13:50:38 -0400
committerMarge Bot <ben+marge-bot@smart-cactus.org>2020-03-31 10:54:20 -0400
commit57b888c0e90be7189285a6b078c30b26d0923809 (patch)
tree2635fd3a7205c11b85392d3ef815e247ea7b17ec /configure.ac
parentf024b6e385bd1448968b7bf20de05f655c815bae (diff)
downloadhaskell-57b888c0e90be7189285a6b078c30b26d0923809.tar.gz
Require GHC 8.8 as the minimum compiler for bootstrapping
This allows us to remove several bits of CPP that are either always true or no longer reachable. As an added bonus, we no longer need to worry about importing `Control.Monad.Fail.fail` qualified to avoid clashing with `Control.Monad.fail`, since the latter is now the same as the former.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2973edd2ab..3718d272c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,8 +158,8 @@ if test "$WithGhc" = ""
then
AC_MSG_ERROR([GHC is required.])
fi
-FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[8.6],
- [AC_MSG_ERROR([GHC version 8.6 or later is required to compile GHC.])])
+FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[8.8],
+ [AC_MSG_ERROR([GHC version 8.8 or later is required to compile GHC.])])
if test `expr $GhcMinVersion % 2` = "1"
then