summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTamar Christina <tamar@zhox.com>2015-10-31 18:12:42 +0100
committerTamar Christina <tamar@zhox.com>2015-10-31 18:12:42 +0100
commit6bef55c6b561080c5ddff73f2c501e40acee86ef (patch)
treedbf2a1960b7f2e39d8d02cfdfd52571dd5f5aca5 /configure.ac
parent7a48e6caad54609f1bbefc3bd60e8352edcd2cc7 (diff)
downloadhaskell-6bef55c6b561080c5ddff73f2c501e40acee86ef.tar.gz
Fix documentation build on windows
Summary: Fix building new Sphinx documenation on Windows in msys2 using Awson's patch on #11021. Install Sphinx using `pacman -S mingw-w64-$(uname -m)-python2-sphinx` Test Plan: Apply patch and ./validate Reviewers: thomie, bgamari, austin Reviewed By: thomie, bgamari Subscribers: erikd Differential Revision: https://phabricator.haskell.org/D1408 GHC Trac Issues: #11021
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 82524b8de1..65e5d77829 100644
--- a/configure.ac
+++ b/configure.ac
@@ -725,11 +725,19 @@ then
fi
dnl ** check for Sphinx toolchain
-AC_PATH_PROG(SPHINXBUILD,sphinx-build)
-AC_CACHE_CHECK([for version of sphinx-build], fp_cv_sphinx_version,
+if test "$HostOS" = "mingw32"
+then
+SphinxBin=sphinx-build2
+else
+SphinxBin=sphinx-build
+fi;
+
+AC_SUBST([SphinxBin])
+AC_PATH_PROG(SPHINXBUILD,${SphinxBin})
+AC_CACHE_CHECK([for version of ${SphinxBin}], fp_cv_sphinx_version,
changequote(, )dnl
[if test -n "$SPHINXBUILD"; then
- fp_cv_sphinx_version=`"$SPHINXBUILD" --version 2>&1 | sed 's/Sphinx\( (sphinx-build)\)\? v\?\([0-9]\.[0-9]\.[0-9]\)/\2/' | head -n1`;
+ fp_cv_sphinx_version=`"$SPHINXBUILD" --version 2>&1 | sed 's/Sphinx\( (sphinx-build[2]\?)\)\? v\?\([0-9]\.[0-9]\.[0-9]\)/\2/' | head -n1`;
fi;
changequote([, ])dnl
])