summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTamar Christina <tamar@zhox.com>2015-11-01 19:26:16 +0100
committerTamar Christina <tamar@zhox.com>2015-11-01 19:26:16 +0100
commit65f3c4c0a1304b8d00b46dc0e77ad93fc566ffb1 (patch)
treeeda6226b6824fa6c5f85469e0bdd307986b5f531 /configure.ac
parente9bfb3fd4cb61621c28b51f0bf0e3d2c6f74e45f (diff)
downloadhaskell-65f3c4c0a1304b8d00b46dc0e77ad93fc566ffb1.tar.gz
Change sphinx for documentation building on windows to the python3 version
Summary: Python 3 seems to have fixed the long standing codepage issue with python on Windows. To be able to reliably build the documentation we should use the Python 3 version of Sphinx. See `https://docs.python.org/dev/whatsnew/3.3.html#codecs` and `https://bugs.python.org/issue13216`. Sphinx also supports Python 3. Oddly enough `python3-sphinx` is registered as `sphinx-build.exe` instead of `sphinx-build3.exe`, so the changes in `configure.ac` can be reverted. install with `pacman -S mingw-w64-$(uname -m)-python3-sphinx` Test Plan: ./validate Reviewers: austin, thomie, bgamari Reviewed By: bgamari Subscribers: erikd Differential Revision: https://phabricator.haskell.org/D1417 GHC Trac Issues: #11021
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 3 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 6bd21030c5..84f381ec17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -725,19 +725,11 @@ then
fi
dnl ** check for Sphinx toolchain
-if test "$HostOS" = "mingw32"
-then
-SphinxBin=sphinx-build2
-else
-SphinxBin=sphinx-build
-fi;
-
-AC_SUBST([SphinxBin])
-AC_PATH_PROG(SPHINXBUILD,${SphinxBin})
-AC_CACHE_CHECK([for version of ${SphinxBin}], fp_cv_sphinx_version,
+AC_PATH_PROG(SPHINXBUILD,sphinx-build)
+AC_CACHE_CHECK([for version of sphinx-build], fp_cv_sphinx_version,
changequote(, )dnl
[if test -n "$SPHINXBUILD"; then
- fp_cv_sphinx_version=`"$SPHINXBUILD" --version 2>&1 | sed 's/Sphinx\( (sphinx-build[2]\?)\)\? v\?\([0-9]\.[0-9]\.[0-9]\)/\2/' | head -n1`;
+ fp_cv_sphinx_version=`"$SPHINXBUILD" --version 2>&1 | sed 's/Sphinx\( (sphinx-build)\)\? v\?\([0-9]\.[0-9]\.[0-9]\)/\2/' | head -n1`;
fi;
changequote([, ])dnl
])