summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <bgamari.foss@gmail.com>2018-06-19 23:16:26 -0400
committerBen Gamari <ben@smart-cactus.org>2018-06-20 11:17:26 -0400
commit942e6c9ecaf12d2834ca5352c6f51e8419efc57c (patch)
treeda2af0b77c2223ebb927598bf14826f924fbcdc8 /configure.ac
parente839ee2f91f9bcd390ead98e830b9e1d7d7b9240 (diff)
downloadhaskell-942e6c9ecaf12d2834ca5352c6f51e8419efc57c.tar.gz
configure: Fix libnuma detection logic
Test Plan: Validate with numa support Subscribers: rwbarton, thomie, erikd, carter Differential Revision: https://phabricator.haskell.org/D4869
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 622ec96daf..1f98407435 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1263,7 +1263,7 @@ if test "$ac_cv_header_numa_h$ac_cv_header_numaif_h" = "yesyes" ; then
AC_CHECK_LIB(numa, numa_available,HaveLibNuma=1)
fi
AC_DEFINE_UNQUOTED([HAVE_LIBNUMA], [$HaveLibNuma], [Define to 1 if you have libnuma])
-if test $HaveLibNuma = "YES" ; then
+if test $HaveLibNuma = "1" ; then
AC_SUBST([CabalHaveLibNuma],[True])
else
AC_SUBST([CabalHaveLibNuma],[False])