summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2011-12-13 19:54:08 +0000
committerIan Lynagh <igloo@earth.li>2011-12-13 19:54:08 +0000
commit4c6dda014a735d2a50c885da99bab908673f9726 (patch)
tree7f2dc4eeaed967a94e52ef8685235dd37953eb84 /configure.ac
parentb9a7206393da57d5b3cd9ae876d254301d266dc0 (diff)
downloadhaskell-4c6dda014a735d2a50c885da99bab908673f9726.tar.gz
HEAD now requires GHC >= 7.0 to bootstrap
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e2add4c4a2..8d747075b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,8 +130,6 @@ if test "$WithGhc" != ""; then
AC_SUBST(GhcPatchLevel)dnl
GhcMinVersion2=`echo "$GhcMinVersion" | sed 's/^\\(.\\)$/0\\1/'`
GhcCanonVersion="$GhcMajVersion$GhcMinVersion2"
- if test $GhcCanonVersion -ge 613; then ghc_ge_613=YES; else ghc_ge_613=NO; fi
- AC_SUBST(ghc_ge_613)dnl
BOOTSTRAPPING_GHC_INFO_FIELD([CC_STAGE0],[C compiler command],['$(CC)'])
BOOTSTRAPPING_GHC_INFO_FIELD([AR_STAGE0],[ar command],['$(AR)'])
@@ -144,8 +142,8 @@ if test "$BootingFromHc" = "NO"; then
if test "$WithGhc" = ""; then
AC_MSG_ERROR([GHC is required unless bootstrapping from .hc files.])
fi
- FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[6.12],
- [AC_MSG_ERROR([GHC version 6.12 or later is required to compile GHC.])])dnl
+ FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[7.0],
+ [AC_MSG_ERROR([GHC version 7.0 or later is required to compile GHC.])])dnl
if test `expr $GhcMinVersion % 2` = "1"; then
if test "$EnableBootstrapWithDevelSnaphost" = "NO"; then