summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGabor Pali <pali.gabor@gmail.com>2012-02-08 17:30:38 +0000
committerIan Lynagh <igloo@earth.li>2012-02-10 21:56:58 +0000
commit7afa5fe18e87f0df7fae35316359cbf9df795363 (patch)
treeee6e5697e764087ae36232980caa4e528f1318dc /configure.ac
parent5e9e07a33e17da01245f0cea78e6a6f8a32ac77d (diff)
downloadhaskell-7afa5fe18e87f0df7fae35316359cbf9df795363.tar.gz
Fix equality testing for test(1) on FreeBSD
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 84f0849689..0ee3969de8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -352,7 +352,7 @@ if test "$build" != "$host" ; then
PortingCompiler=YES
fi
# Note: cross_compiling is set to 'yes' in both 'port' and 'toolchain' cases
-if ! test "$host" == "$target" -o "$host" == "$build" ; then
+if ! test "$host" = "$target" -o "$host" = "$build" ; then
AC_MSG_ERROR([
You've selected: