summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2015-12-18 11:57:52 +0100
committerBen Gamari <ben@smart-cactus.org>2015-12-18 13:31:47 +0100
commit53a567c59f497d1af0ed5cc3c235c71701ed8cea (patch)
tree9282bacba2e6301b3d11407c8d9fe5b2a4768f1d /configure.ac
parent8946ee6de770411f185007a2853c290a9a021638 (diff)
downloadhaskell-53a567c59f497d1af0ed5cc3c235c71701ed8cea.tar.gz
configure.ac: Rename shake/ to build/
See https://github.com/snowleopard/shaking-up-ghc/pull/2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0f335a48a3..d1f8115cf2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1098,9 +1098,11 @@ if grep ' ' compiler/ghc.cabal.in 2>&1 >/dev/null; then
AC_MSG_ERROR([compiler/ghc.cabal.in contains tab characters; please remove them])
fi
-if test -e shake/cfg/system.config.in; then
- AC_CONFIG_FILES([shake/cfg/system.config])
+# Create the configuration for the Shake-based build system if it is present
+if test -e build/cfg/system.config.in; then
+ AC_CONFIG_FILES([build/cfg/system.config])
fi
+
AC_CONFIG_FILES([mk/config.mk mk/install.mk mk/project.mk compiler/ghc.cabal ghc/ghc-bin.cabal utils/runghc/runghc.cabal settings docs/users_guide/ghc_config.py docs/index.html libraries/prologue.txt distrib/configure.ac])
AC_OUTPUT