summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Z. Yang <ezyang@cs.stanford.edu>2015-10-11 13:41:20 -0700
committerEdward Z. Yang <ezyang@cs.stanford.edu>2015-10-14 21:40:58 -0700
commit6338a1cc6df2c7fd8a62eeb4c5240dd90ee74a6c (patch)
treec2a14d6f908cf76e4d3b71342dc36d781bc2e40d /configure.ac
parentb92a51f5e235fc22a9ae0d76735b50f095665fb7 (diff)
downloadhaskell-6338a1cc6df2c7fd8a62eeb4c5240dd90ee74a6c.tar.gz
Rename PACKAGE_KEY and LIB_NAME in build system.
Signed-off-by: Edward Z. Yang <ezyang@cs.stanford.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 832ca22a06..aba71a3eb4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,9 +160,9 @@ FP_COMPARE_VERSIONS([$GhcVersion],[-gt],[7.7],
AC_SUBST(CMM_SINK_BOOTSTRAP_IS_NEEDED)
FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[7.9],
- SUPPORTS_PACKAGE_KEY=NO,
- SUPPORTS_PACKAGE_KEY=YES)
-AC_SUBST(SUPPORTS_PACKAGE_KEY)
+ SUPPORTS_COMPONENT_ID=NO,
+ SUPPORTS_COMPONENT_ID=YES)
+AC_SUBST(SUPPORTS_COMPONENT_ID)
# GHC is passed to Cabal, so we need a native path
if test "${WithGhc}" != ""