summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDemi Obenour <demiobenour@gmail.com>2017-01-20 16:49:53 -0500
committerBen Gamari <ben@smart-cactus.org>2017-01-20 16:49:54 -0500
commitc43011da283bfcef664378bb451d5f3bffcdbe92 (patch)
tree7371563d7922d32a660c495f055935d083998d4c /configure.ac
parentb626a00113ecdb960ba642f0ce31e2ff71892b4d (diff)
downloadhaskell-c43011da283bfcef664378bb451d5f3bffcdbe92.tar.gz
Clean up some shell code and M4 quoting
Test Plan: GHC CI Reviewers: austin, hvr, bgamari Reviewed By: bgamari Subscribers: thomie, erikd Differential Revision: https://phabricator.haskell.org/D2993
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 16 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 4502c5343a..a7100cc45a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,7 +120,7 @@ AC_ARG_VAR(CC_STAGE0, [C compiler command (bootstrap)])
if test "$WithGhc" != ""; then
FPTOOLS_GHC_VERSION([GhcVersion], [GhcMajVersion], [GhcMinVersion], [GhcPatchLevel])dnl
- if test "$GhcMajVersion" = "unknown" -o "$GhcMinVersion" = "unknown"; then
+ if test "$GhcMajVersion" = "unknown" || test "$GhcMinVersion" = "unknown"; then
AC_MSG_ERROR([Cannot determine the version of $WithGhc. Is it really GHC?])
fi
@@ -1144,7 +1144,7 @@ checkMake380 gmake
AC_CONFIG_FILES([mk/config.mk mk/install.mk mk/project.mk compiler/ghc.cabal ghc/ghc-bin.cabal utils/runghc/runghc.cabal libraries/ghc-boot/ghc-boot.cabal libraries/ghc-boot-th/ghc-boot-th.cabal libraries/ghci/ghci.cabal settings docs/users_guide/ghc_config.py docs/index.html libraries/prologue.txt utils/mkUserGuidePart/mkUserGuidePart.cabal distrib/configure.ac])
AC_OUTPUT
-
+[
if test "$print_make_warning" = "true"; then
echo
echo "WARNING: It looks like \"$MakeCmd\" is GNU make 3.80."
@@ -1152,7 +1152,7 @@ if test "$print_make_warning" = "true"; then
echo "Please use GNU make >= 3.81."
fi
-echo ["
+echo "
----------------------------------------------------------------------
Configure completed successfully.
@@ -1162,12 +1162,12 @@ Configure completed successfully.
Build platform : $BuildPlatform
Host platform : $HostPlatform
Target platform : $TargetPlatform
-"]
+"
-echo ["\
+echo "\
Bootstrapping using : $WithGhc
which is version : $GhcVersion
-"]
+"
if test "x$CC_LLVM_BACKEND" = "x1"; then
if test "x$CC_CLANG_BACKEND" = "x1"; then
@@ -1179,7 +1179,7 @@ else
CompilerName="gcc "
fi
-echo ["\
+echo "\
Using (for bootstrapping) : $CC_STAGE0
Using $CompilerName : $CC
which is version : $GccVersion
@@ -1198,24 +1198,24 @@ echo ["\
Using LLVM tools
llc : $LlcCmd
- opt : $OptCmd"]
+ opt : $OptCmd"
if test "$HSCOLOUR" = ""; then
-echo ["
+echo "
HsColour was not found; documentation will not contain source links
-"]
+"
else
-echo ["\
+echo "\
HsColour : $HSCOLOUR
-"]
+"
fi
-echo ["\
+echo "\
Tools to build Sphinx HTML documentation available: $BUILD_SPHINX_HTML
Tools to build Sphinx PDF documentation available: $BUILD_SPHINX_PDF"]
-echo ["----------------------------------------------------------------------
-"]
+echo "----------------------------------------------------------------------
+"
echo "\
For a standard build of GHC (fully optimised with profiling), type (g)make.
@@ -1225,4 +1225,4 @@ mk/build.mk.sample to mk/build.mk, and edit the settings in there.
For more information on how to configure your GHC build, see
http://ghc.haskell.org/trac/ghc/wiki/Building
-"
+"]