summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Marlow <simonmar@microsoft.com>2007-11-26 14:16:14 +0000
committerSimon Marlow <simonmar@microsoft.com>2007-11-26 14:16:14 +0000
commitfc3ed3199e11aa4b9434e52436d98083ddac0cd0 (patch)
tree5a5272d12136183fdca1d527ea8a9fbac9ba9fb4 /configure.ac
parent836cafeb3edd9c728fe4c86cf90229e1476ad14a (diff)
downloadhaskell-fc3ed3199e11aa4b9434e52436d98083ddac0cd0.tar.gz
canonicalise the path to HsColour
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 84d6c6df05..66ed8a0b86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -928,6 +928,15 @@ dnl if GNU tar is named gtar, look for it first.
AC_PATH_PROGS(TarCmd,gtar tar,tar)
AC_PATH_PROG(HSCOLOUR,HsColour)
+# HsColour is passed to Cabal, so we need a native path
+if test "x$HostPlatform" = "xi386-unknown-mingw32"
+ then
+ if test "${OSTYPE}" != "msys"
+ then
+ # Canonicalise to <drive>:/path/to/gcc
+ HSCOLOUR=`cygpath -w ${HSCOLOUR} | sed -e 's@\\\\@/@g' `
+ fi
+fi
dnl ** check for DocBook toolchain
FP_CHECK_DOCBOOK_DTD