summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorClemens Fruhwirth <clemens@endorphin.org>2007-08-08 06:50:43 +0000
committerClemens Fruhwirth <clemens@endorphin.org>2007-08-08 06:50:43 +0000
commit006a18ea83799c0d4255071a2f8c08d3e9c7d84f (patch)
treebf73abdd6f0d50df5dc991a0d8c39d6c6a8a1be6 /configure.ac
parent90ef8ab26efb2fc4172944f1066f122d3a6e7c7d (diff)
downloadhaskell-006a18ea83799c0d4255071a2f8c08d3e9c7d84f.tar.gz
Build RTS as dynamic library
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e37972124c..929b6404a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,6 +100,7 @@ if test x"$TargetPlatform" != x"$HostPlatform" ; then
fi
exeext=''
+soext='.so'
#
# The following will be more difficult when we *are* cross-compiling.
# Suitable names to slam in *_CPP are in platform.h.in.
@@ -295,6 +296,7 @@ i[[3456]]86-*-cygwin*)
HostVendor_CPP='unknown'
HostOS_CPP='cygwin32'
exeext='.exe'
+ soext='.dll'
;;
i[[3456]]86-*-mingw32*)
HostPlatform=i386-unknown-mingw32 # hack again
@@ -305,6 +307,7 @@ i[[3456]]86-*-mingw32*)
HostVendor_CPP='unknown'
HostOS_CPP='mingw32'
exeext='.exe'
+ soext='.dll'
;;
i[[3456]]86-apple-darwin*)
HostPlatform=i386-apple-darwin
@@ -314,6 +317,7 @@ i[[3456]]86-apple-darwin*)
HostArch_CPP='i386'
HostVendor_CPP='apple'
HostOS_CPP='darwin'
+ soext='.dylib'
;;
i[[3456]]86-*-gnu*)
HostPlatform=i386-unknown-gnu
@@ -350,6 +354,7 @@ x86_64-apple-darwin*)
HostArch_CPP='x86_64'
HostVendor_CPP='apple'
HostOS_CPP='darwin'
+ soext='.dylib'
;;
m68k-*-linux*)
HostPlatform=m68k-unknown-linux # hack again
@@ -476,6 +481,7 @@ powerpc-apple-darwin*)
HostArch_CPP='powerpc'
HostVendor_CPP='apple'
HostOS_CPP='darwin'
+ soext='.dylib'
;;
powerpc-unknown-linux*)
HostPlatform=powerpc-unknown-linux
@@ -608,6 +614,7 @@ AC_SUBST(BuildVendor_CPP)
AC_SUBST(TargetVendor_CPP)
AC_SUBST(exeext)
+AC_SUBST(soext)
dnl --------------------------------------------------------------
dnl * Project specific configuration options