summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Marlow <marlowsd@gmail.com>2011-08-10 09:10:24 +0100
committerSimon Marlow <marlowsd@gmail.com>2011-08-10 09:49:50 +0100
commita0d1b8a97af94e15783fee2ebbf46c69ac881a0f (patch)
treee00d5eed6b4380085b3911b224de6f54475e5868 /configure.ac
parent270865785d730eafabc5717bfcfa344a1f8498ad (diff)
downloadhaskell-a0d1b8a97af94e15783fee2ebbf46c69ac881a0f.tar.gz
Fail configure if Alex 3 is found. Haddock doesn't build with Alex 3
yet, and fixing it is non-trivial (a change to Cabal is needed). So I'm making configure fail with an error suggesting to install an older Alex for now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 29185d3ca3..f2aba416ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -608,6 +608,9 @@ dnl ** check for installed alex binary + version
dnl (don't do it if we're booting from .hc files though.)
if test "$BootingFromHc" = "NO"; then
FPTOOLS_ALEX
+if test "${Alex3}" = "YES"; then
+ AC_MSG_ERROR([GHC does not build with Alex 3 yet; please install an older version (we hope to fix this soon).])
+fi
fi;
dnl --------------------------------------------------