summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Ericson <git@JohnEricson.me>2019-09-03 21:10:59 -0400
committerMarge Bot <ben+marge-bot@smart-cactus.org>2019-09-05 18:50:56 -0400
commitb55ee979d32df938eee9c4c02c189f8be267e8a1 (patch)
treec1d1006c0ddd76f85c05a9258d687a32d2f6ce96 /configure.ac
parentf96d57b800f10ab194897133f3c0d11e4fbc71b4 (diff)
downloadhaskell-b55ee979d32df938eee9c4c02c189f8be267e8a1.tar.gz
Make sure all boolean settings entries use `YES` / `NO`
Some where using `True` / `False`, a legacy of when they were in `Config.hs`. See #16914 / d238d3062a9858 for a similar problem. Also clean up the configure variables names for consistency and clarity while we're at it. "Target" makes clear we are talking about outputted code, not where GHC itself runs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9fc54fc218..470de218ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -324,13 +324,13 @@ dnl ** Does target have runtime linker support?
dnl --------------------------------------------------------------
case "$target" in
powerpc64-*|powerpc64le-*|powerpc-ibm-aix*)
- HaskellHaveRTSLinker=NO
+ TargetHasRTSLinker=NO
;;
*)
- HaskellHaveRTSLinker=YES
+ TargetHasRTSLinker=YES
;;
esac
-AC_SUBST(HaskellHaveRTSLinker)
+AC_SUBST(TargetHasRTSLinker)
# Requires FPTOOLS_SET_PLATFORM_VARS to be run first.
FP_FIND_ROOT