summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@community.haskell.org>2011-03-01 19:40:18 +0000
committerSergei Trofimovich <slyfox@community.haskell.org>2011-03-01 19:40:18 +0000
commite45b7db233c7c315612b5e1b2e82f872784507ee (patch)
treef6525aec57d2e0406ec59cd2dae67077164a401e /configure.ac
parentc00ea87f79231fba729fd4e7de1279261044ce5f (diff)
downloadhaskell-e45b7db233c7c315612b5e1b2e82f872784507ee.tar.gz
configure: amend sanity check
As we perform some mangling of original --build/--host/--target params we should check the result of mangling against desired triplet, not originally passed by user. Patch also adds mangled triplets to the output.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 967fd6f730..67cf25f9fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,7 +288,7 @@ checkOS "$TargetOS"
# Verify that the installed (bootstrap) GHC is capable of generating
# code for the requested build platform.
-if test "$build" != "$bootstrap_target"
+if test "$BuildPlatform" != "$bootstrap_target"
then
echo "This GHC (${WithGhc}) does not generate code for the build platform"
echo " GHC target platform : $bootstrap_target"
@@ -296,6 +296,10 @@ then
exit 1
fi
+echo "GHC build : $BuildPlatform"
+echo "GHC host : $HostPlatform"
+echo "GHC target : $TargetPlatform"
+
AC_SUBST(BuildPlatform)
AC_SUBST(HostPlatform)
AC_SUBST(TargetPlatform)