summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTuncer Ayaz <tuncer.ayaz@gmail.com>2014-11-26 16:31:53 +0100
committerAustin Seipp <austin@well-typed.com>2014-11-26 17:16:45 -0600
commit4897e7056e7b34c42ba5c0b1fa28ea547b8085b3 (patch)
treeeee5685dbd75fa74d36a3b105470909c6c873195 /configure.ac
parented56c023e3e2e3d2a9fe18a17e2131d9a55c69a5 (diff)
downloadhaskell-4897e7056e7b34c42ba5c0b1fa28ea547b8085b3.tar.gz
configure.ac: fix test == bashism
Signed-off-by: Austin Seipp <austin@well-typed.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5dd3aaa5c3..ca9f220d40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -560,7 +560,7 @@ then
# Check whether LLVM backend is default for this platform
"${WithGhc}" conftestghc.hs 2>&1 >/dev/null
res=`./conftestghc`
- if test "x$res" == "x%object"
+ if test "x$res" = "x%object"
then
AC_MSG_RESULT(yes)
echo "Buggy bootstrap compiler"
@@ -576,14 +576,14 @@ then
# -fllvm is not the default, but set a flag so the Makefile can check
# -for it in the build flags later on
"${WithGhc}" -fforce-recomp -fllvm conftestghc.hs 2>&1 >/dev/null
- if test $? == 0
+ if test $? = 0
then
res=`./conftestghc`
- if test "x$res" == "x%object"
+ if test "x$res" = "x%object"
then
AC_MSG_RESULT(yes)
GHC_LLVM_AFFECTED_BY_9439=1
- elif test "x$res" == "x%function"
+ elif test "x$res" = "x%function"
then
AC_MSG_RESULT(no)
GHC_LLVM_AFFECTED_BY_9439=0