summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Gardas <karel.gardas@centrum.cz>2014-02-09 21:58:05 +0100
committerAustin Seipp <austin@well-typed.com>2014-03-22 19:39:43 -0500
commitac24bf45258af701cdd67423d6107357f27bbedf (patch)
treec9c67edfe61937146787da3f0863492fc638e64f /configure.ac
parentd523f9b3d4ce3463e8816cad2139ea397e00f8d1 (diff)
downloadhaskell-ac24bf45258af701cdd67423d6107357f27bbedf.tar.gz
add --with-ar and --with-ranlib configure parameters
Both --with-ar and --with-ranlib are usable on non-GNU/Linux systems where GNU tools are usually installed (or possible to install), but not into standard location nor with standard name. Tested on Solaris 10. Signed-off-by: Austin Seipp <austin@well-typed.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e7fbc7f9d0..244fcc0a1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -486,6 +486,21 @@ FP_ARG_WITH_PATH_GNU_PROG([NM], [nm], [nm])
NmCmd="$NM"
AC_SUBST([NmCmd])
+dnl ** Which ar to use?
+dnl --------------------------------------------------------------
+FP_ARG_WITH_PATH_GNU_PROG([AR], [ar], [ar])
+ArCmd="$AR"
+fp_prog_ar="$AR"
+AC_SUBST([ArCmd])
+
+dnl ** Which ranlib to use?
+dnl --------------------------------------------------------------
+FP_ARG_WITH_PATH_GNU_PROG([RANLIB], [ranlib], [ranlib])
+RanlibCmd="$RANLIB"
+RANLIB="$RanlibCmd"
+AC_SUBST([RanlibCmd])
+
+
# Note: we may not have objdump on OS X, and we only need it on Windows (for DLL checks)
case $HostOS_CPP in
cygwin32|mingw32)