summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRyan Scott <ryan.gl.scott@gmail.com>2021-03-05 19:13:39 -0500
committerMarge Bot <ben+marge-bot@smart-cactus.org>2021-03-09 02:46:20 -0500
commit0a709dd9876e40c19c934692415c437ac434318c (patch)
tree0ac02b3eb1d1397cf0bfa495c84b0ff2e8834bde /configure.ac
parentbfa862503a9f8b2e8a61b9499d2cc3be789779fd (diff)
downloadhaskell-0a709dd9876e40c19c934692415c437ac434318c.tar.gz
Require GHC 8.10 as the minimum compiler for bootstrapping
Now that GHC 9.0.1 is released, it is time to drop support for bootstrapping with GHC 8.8, as we only support building with the previous two major GHC releases. As an added bonus, this allows us to remove several bits of CPP that are either always true or no longer reachable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fcf74567d3..2645ee5aa1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -191,8 +191,8 @@ if test "$WithGhc" = ""
then
AC_MSG_ERROR([GHC is required.])
fi
-FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[8.8],
- [AC_MSG_ERROR([GHC version 8.8 or later is required to compile GHC.])])
+FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[8.10],
+ [AC_MSG_ERROR([GHC version 8.10 or later is required to compile GHC.])])
if test `expr $GhcMinVersion % 2` = "1"
then