summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Gröber <dxld@darkboxed.org>2021-02-15 04:07:23 +0100
committerMarge Bot <ben+marge-bot@smart-cactus.org>2021-07-29 13:12:47 -0400
commite6731578246b6e6959026d4a9da9971b097c83aa (patch)
treeb187c46fc1d10b17a1f7d2a5952582269921b73a /configure.ac
parent296ed7395c9a45352cf2e03ef9ff0b3b1f5a1a80 (diff)
downloadhaskell-e6731578246b6e6959026d4a9da9971b097c83aa.tar.gz
Add configure flag to enable ASSERTs in all ways
Running the test suite with asserts enabled is somewhat tricky at the moment as running it with a GHC compiled the DEBUG way has some hundred failures from the start. These seem to be unrelated to assertions though. So this provides a toggle to make it easier to debug failing assertions using the test suite.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1b9ebd309f..7563ed5af9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,6 +123,17 @@ if test "$EnableDistroToolchain" = "YES"; then
TarballsAutodownload=NO
fi
+AC_ARG_ENABLE(asserts-all-ways,
+[AC_HELP_STRING([--enable-asserts-all-ways],
+ [Usually ASSERTs are only compiled in the DEBUG way,
+ this will enable them in all ways.])],
+ EnableAssertsAllWays=YES,
+ EnableAssertsAllWays=NO
+)
+if test "$enable_asserts_all_ways" = "yes" ; then
+ AC_DEFINE([USE_ASSERTS_ALL_WAYS], [1], [Compile-in ASSERTs in all ways.])
+fi
+
AC_ARG_ENABLE(native-io-manager,
[AS_HELP_STRING([--enable-native-io-manager],
[Enable the native I/O manager by default.])],
@@ -135,6 +146,7 @@ if test "$EnableNativeIOManager" = "YES"; then
fi
+
dnl CC_STAGE0, LD_STAGE0, AR_STAGE0 are like the "previous" variable
dnl CC, LD, AR (inherited by CC_STAGE[123], etc.)
dnl but instead used by stage0 for bootstrapping stage1