summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorstolz <unknown>2004-11-18 16:39:54 +0000
committerstolz <unknown>2004-11-18 16:39:54 +0000
commit16ccba3a61c313da357749e548a533742ad9aedd (patch)
treebb584a88a154e3e657429b3e7e05faf6e6bada8d /configure.ac
parentb61f70ce5ff947642c96b1ad980351691bb1e07a (diff)
downloadhaskell-16ccba3a61c313da357749e548a533742ad9aedd.tar.gz
[project @ 2004-11-18 16:39:53 by stolz]
Push down more feature-tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 28debbc33c..1e2ad95642 100644
--- a/configure.ac
+++ b/configure.ac
@@ -955,8 +955,6 @@ AC_SYS_LARGEFILE
dnl ** check for specific header (.h) files that we are interested in
AC_CHECK_HEADERS([bfd.h ctype.h dirent.h dlfcn.h errno.h fcntl.h grp.h limits.h locale.h nlist.h pthread.h pwd.h signal.h sys/mman.h sys/resource.h sys/time.h sys/timeb.h sys/timers.h sys/times.h sys/utsname.h sys/wait.h termios.h time.h utime.h windows.h winsock.h])
-AC_CHECK_HEADER([unistd.h], [AC_CHECK_FUNCS(lchown)])
-
AC_CHECK_HEADER([readline/readline.h], [HaveReadlineReadlineH=YES], [HaveReadlineReadlineH=NO])
AC_CHECK_HEADER([readline/history.h], [HaveReadlineHistoryH=YES], [HaveReadlineHistoryH=NO])
@@ -1100,7 +1098,10 @@ if test "$ac_cv_type_signal" = void; then
fi
dnl ** check for more functions
-AC_CHECK_FUNCS([ftime getclock getpagesize getrusage gettimeofday gmtime_r localtime_r lstat readdir_r readlink setenv setitimer siginterrupt symlink sysconf times unsetenv])
+dnl ** The following have been verified to be used in ghc/, but might be used somewhere else, too.
+AC_CHECK_FUNCS([getclock getrusage gettimeofday setitimer siginterrupt sysconf times])
+dnl ** For ghc/rts/gmp:
+AC_CHECK_FUNCS([getpagesize])
dnl ** check whether this machine has gmp3 installed
AC_CHECK_LIB(gmp, __gmpz_fdiv_qr, HaveLibGmp=YES; LibGmp=gmp,