summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorstolz <unknown>2004-11-12 12:12:53 +0000
committerstolz <unknown>2004-11-12 12:12:53 +0000
commit204c40fa155dfc77d82eede798344b911cf89799 (patch)
tree90627ba5376386575fd56197ed0e124907069629 /configure.ac
parent38cd621581180a8cb5ba2d465c559f5e1659e5d2 (diff)
downloadhaskell-204c40fa155dfc77d82eede798344b911cf89799.tar.gz
[project @ 2004-11-12 12:12:52 by stolz]
Push some unixisms from toplvl into package: usleep, SunOS-handling, getpw*
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 1 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 0549583634..4be09b7ab3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1100,15 +1100,7 @@ if test "$ac_cv_type_signal" = void; then
fi
dnl ** check for more functions
-AC_CHECK_FUNCS([ftime getclock getgrgid_r getgrnam_r getpagesize getpwnam_r getpwuid_r getpwnam getpwuid getrusage gettimeofday gmtime_r localtime_r lstat readdir_r readlink setenv setitimer siginterrupt symlink sysconf times unsetenv])
-
-dnl ** Solaris2 needs additionl flag for getpw*_r()
-case "$TargetPlatform" in
- *-solaris2*)
- unix_SRC_HSC2HS_OPTS="-D_POSIX_PTHREAD_SEMANTICS"
- AC_SUBST(unix_SRC_HSC2HS_OPTS)
- ;;
-esac
+AC_CHECK_FUNCS([ftime getclock getpagesize getrusage gettimeofday gmtime_r localtime_r lstat readdir_r readlink setenv setitimer siginterrupt symlink sysconf times unsetenv])
dnl ** check whether this machine has gmp3 installed
AC_CHECK_LIB(gmp, __gmpz_fdiv_qr, HaveLibGmp=YES; LibGmp=gmp,
@@ -1308,23 +1300,6 @@ else
AC_SUBST(HaveRtldNow)
fi
-dnl ---------- usleep ----------
-dnl --- stolen from guile configure ---
-dnl --- FIXME: /usr/include/unistd.h can't be right?
-
-### On some systems usleep has no return value. If it does have one,
-### we'd like to return it; otherwise, we'll fake it.
-AC_CACHE_CHECK([return type of usleep], cv_func_usleep_return_type,
- [AC_EGREP_HEADER(changequote(<, >)<void[ ]+usleep>changequote([, ]),
- /usr/include/unistd.h,
- [cv_func_usleep_return_type=void],
- [cv_func_usleep_return_type=int])])
-case "$cv_func_usleep_return_type" in
- "void" )
- AC_DEFINE([USLEEP_RETURNS_VOID], [1], [Define if the system headers declare usleep to return void.])
- ;;
-esac
-
dnl --------------------------------------------------
dnl * test for GTK+
dnl --------------------------------------------------