summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpanne <unknown>2004-09-18 12:50:00 +0000
committerpanne <unknown>2004-09-18 12:50:00 +0000
commitced47f78e954f1700d692887735b3246a348b6c3 (patch)
treebb98266c91d789e6dc1966bd83ab41a185df3e6f /configure.ac
parent9eb6cb808766126461564120923eb5d983221843 (diff)
downloadhaskell-ced47f78e954f1700d692887735b3246a348b6c3.tar.gz
[project @ 2004-09-18 12:49:55 by panne]
Make autoupdate 2.52 happy, mainly by using the new formats of AC_INIT and AC_OUTPUT. This has the nice side effect that all "packages" have now a name, a version, a bug-report address, and a tar name, yielding better output with "configure --help=recursive". Nuked an unused AC_STRUCT_ST_BLKSIZE test on the way.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 8 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index bdccd702ab..a8a484b715 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,8 +13,10 @@ dnl
# see what flags are available. (Better yet, read the documentation!)
#
+AC_INIT([fptools build system], [1.0], [cvs-fptools@haskell.org], [fptools])
+
# First off, a distrib sanity check..
-AC_INIT(mk/config.mk.in)
+AC_CONFIG_SRCDIR([mk/config.mk.in])
dnl * We require autoconf version 2.52
dnl We need 2.50 due to the use of AC_SYS_LARGEFILE and AC_MSG_NOTICE.
@@ -45,7 +47,7 @@ dnl * Choose host(/target/build) platform
dnl--------------------------------------------------------------------
dnl Guess host/target/build platform(s) if necessary.
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_TARGET
# "$host" defaults to "$target"
if test "x$host" = xNONE ; then
@@ -995,9 +997,6 @@ AC_STRUCT_TIMEZONE
dnl ** do we have altzone?
FP_DECL_ALTZONE
-dnl ** does struct stat contain st_blksize?
-AC_STRUCT_ST_BLKSIZE
-
dnl ** do we have long longs?
AC_CHECK_TYPES([long long])
@@ -1380,7 +1379,7 @@ dnl ** can we get alloca?
AC_FUNC_ALLOCA
dnl ** Working vfork?
-AC_FUNC_VFORK
+AC_FUNC_FORK
dnl ** determine whether or not const works
AC_C_CONST
@@ -1410,4 +1409,6 @@ FPTOOLS_LD_X
FP_EMPTY_STRUCTS
-AC_OUTPUT(mk/config.mk, echo timestamp > mk/stamp-h )
+AC_CONFIG_FILES([mk/config.mk])
+AC_CONFIG_COMMANDS([mk/stamp-h],[echo timestamp > mk/stamp-h])
+AC_OUTPUT