summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorwolfgang <unknown>2005-07-15 02:00:15 +0000
committerwolfgang <unknown>2005-07-15 02:00:15 +0000
commitde6f23d475854795e15595f4b85fb1b389cdd651 (patch)
treeeb894dcd606756477e3060a19faf04bce5961b32 /configure.ac
parent834e82079c32fa24eb6e0beb6f202add9379dc49 (diff)
downloadhaskell-de6f23d475854795e15595f4b85fb1b389cdd651.tar.gz
[project @ 2005-07-15 02:00:15 by wolfgang]
Mac OS X/PowerPC: Make GHCi deal with the additional statically linked symbols from libSystemStub.a on Tiger (printf$LDBLStub and friends). MERGE TO STABLE
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a61bb0448e..a71049a9c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1270,6 +1270,21 @@ AC_TRY_COMPILE(,[__asm__ (".subsections_via_symbols");],
[Define to 1 if Apple-style dead-stripping is supported.])
])
+dnl ** check for Apple's "interesting" long double compatibility scheme
+AC_MSG_CHECKING(for printf$LDBLStub)
+AC_TRY_LINK_FUNC(printf$LSBLStub,
+ [
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_PRINTF_LDBLSTUB],[1],
+ [Define to 1 if we have printf$LDBLStub (Apple Mac OS >= 10.4, PPC).])
+ ],
+ [
+ AC_MSG_RESULT(no)
+ AC_DEFINE([HAVE_PRINTF_LDBLSTUB],[0],
+ [Define to 1 if we have printf$LDBLStub (Apple Mac OS >= 10.4, PPC).])
+ ])
+
+
AC_CONFIG_FILES([mk/config.mk])
AC_CONFIG_COMMANDS([mk/stamp-h],[echo timestamp > mk/stamp-h])
AC_OUTPUT