summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2009-08-08 22:25:37 +0000
committerIan Lynagh <igloo@earth.li>2009-08-08 22:25:37 +0000
commit0e7a5fb9473f7dbba3be791118f66078293246d7 (patch)
tree7373153b066905f10e7517bc2e0a8da0f618ca39 /configure.ac
parentc56aacad40b7afc8244676a4de5fa976cfd4cfb7 (diff)
downloadhaskell-0e7a5fb9473f7dbba3be791118f66078293246d7.tar.gz
Pass -m32 to gcc on i386 and ppc OS X
This makes GHC work even if you are actually running it in 64bit mode, e.g. on OS X 10.6 Snow.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31baed26da..dcea6e1382 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,6 +242,10 @@ case $host in
;;
i386-apple-darwin|powerpc-apple-darwin)
soext='.dylib'
+ CFLAGS="$CFLAGS -m32"
+ LDFLAGS="$LDFLAGS -m32"
+ SRC_CC_OPTS="$SRC_CC_OPTS -m32"
+ SRC_LD_OPTS="$SRC_LD_OPTS -m32"
;;
x86_64-apple-darwin)
soext='.dylib'