summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTamar Christina <tamar@zhox.com>2020-08-23 12:53:14 +0100
committerMarge Bot <ben+marge-bot@smart-cactus.org>2020-08-28 02:23:13 -0400
commit4517a38215eb72a4824c72d97377b9325059bf55 (patch)
tree402acc3b8a69f782988f3b282bf9a1fa055503f4 /configure.ac
parentf065b6b012fb8f73689bc5c2a4904d5e6e377af8 (diff)
downloadhaskell-4517a38215eb72a4824c72d97377b9325059bf55.tar.gz
document how build system find toolchains on Windows
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a422d7ff9..5e3dfa5470 100644
--- a/configure.ac
+++ b/configure.ac
@@ -435,6 +435,7 @@ set_up_tarballs() {
fi
}
+# See Note [tooldir: How GHC finds mingw on Windows]
if test "$HostOS" = "mingw32" -a "$EnableDistroToolchain" = "NO"
then
test -d inplace || mkdir inplace
@@ -455,6 +456,7 @@ fi
# We don't want to bundle a MinGW-w64 toolchain
# So we have to find these individual tools.
+# See Note [tooldir: How GHC finds mingw on Windows]
if test "$EnableDistroToolchain" = "YES"
then
# Ideally should use AC_CHECK_TARGET_TOOL but our triples