summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2021-07-21 09:22:06 -0400
committerMarge Bot <ben+marge-bot@smart-cactus.org>2021-07-27 04:47:51 -0400
commit63184a71277aa15608659ad20f45b7b0fe9746bc (patch)
tree09ebc39bfc16ec045931be9abd39005a144d5bf8 /configure.ac
parentdd3c9602fdb0d408509d166cc0bf05777753ca43 (diff)
downloadhaskell-63184a71277aa15608659ad20f45b7b0fe9746bc.tar.gz
rts: Don't declare libCffi as bundled when using system libffi
Previously the rts's cabal file would claim that it bundled libffi, even if we are using the system's libffi. Fixes #19869.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 535a0c3b88..b91c86f1ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1083,10 +1083,12 @@ AC_ARG_WITH([system-libffi],
])
AS_IF([test "x$with_system_libffi" = "xyes"],
- [UseSystemLibFFI="YES"], [UseSystemLibFFI="NO"]
+ [UseSystemLibFFI="YES"; CabalUseSystemLibFFI="True"],
+ [UseSystemLibFFI="NO"; CabalUseSystemLibFFI="True"]
)
AC_SUBST(UseSystemLibFFI)
+AC_SUBST(CabalUseSystemLibFFI)
AC_ARG_WITH([ffi-includes],
[AS_HELP_STRING([--with-ffi-includes=ARG],