summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2021-01-17 11:26:48 -0500
committerMarge Bot <ben+marge-bot@smart-cactus.org>2021-01-30 14:12:24 -0500
commit55ef3bdc28681a22ceccf207707c49229f9b7559 (patch)
treed2cc7ebbd4796df1de120fbec8284c55a661a9ce /configure.ac
parent621d8cf7fe0bbfa8893dc739120c7f3b12a6f472 (diff)
downloadhaskell-55ef3bdc28681a22ceccf207707c49229f9b7559.tar.gz
hadrian: Introduce ghci-wrapper package
This wraps the existing GHCi wrapper script (driver/ghci/ghci.c) in a cabal file and adds the package to Hadrian.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1ec0a6f621..d69ff312b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -751,7 +751,7 @@ dnl --------------------------------------------------------------
dnl ** Copy the files from the "fs" utility into the right folders.
dnl --------------------------------------------------------------
-AC_MSG_NOTICE([Creating links for in-tree file handling routines.])
+AC_MSG_NOTICE([Creating links for in-tree file handling routines])
ln -f utils/fs/fs.* utils/lndir/
ln -f utils/fs/fs.* utils/unlit/
ln -f utils/fs/fs.* rts/
@@ -759,6 +759,18 @@ ln -f utils/fs/fs.h libraries/base/include/
ln -f utils/fs/fs.c libraries/base/cbits/
AC_MSG_NOTICE([Routines in place. Packages can now be build normally.])
+dnl ** Copy files for ghci wrapper C utilities.
+dnl --------------------------------------------------------------
+dnl See Note [Hadrian's ghci-wrapper package] in hadrian/src/Packages.hs
+AC_MSG_NOTICE([Creating links for ghci wrapper])
+ln -f driver/utils/getLocation.c driver/ghci/
+ln -f driver/utils/getLocation.h driver/ghci/
+ln -f driver/utils/isMinTTY.c driver/ghci/
+ln -f driver/utils/isMinTTY.h driver/ghci/
+ln -f driver/utils/cwrapper.c driver/ghci/
+ln -f driver/utils/cwrapper.h driver/ghci/
+AC_MSG_NOTICE([done.])
+
dnl --------------------------------------------------------------
dnl ** Can the unix package be built?
dnl --------------------------------------------------------------
@@ -1505,6 +1517,7 @@ AC_CONFIG_FILES(
compiler/ghc.cabal
ghc/ghc-bin.cabal
utils/runghc/runghc.cabal
+ driver/ghci/ghci-wrapper.cabal
utils/iserv/iserv.cabal
utils/iserv-proxy/iserv-proxy.cabal
utils/remote-iserv/remote-iserv.cabal