summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHerbert Valerio Riedel <hvr@gnu.org>2015-12-06 13:34:34 +0100
committerHerbert Valerio Riedel <hvr@gnu.org>2015-12-06 21:11:33 +0100
commit8b422142421c751d2c7fa7840afa61f923afdbe1 (patch)
tree257f617171c05661d51ecdb5ce83a7b5cce84ee4 /configure.ac
parent986ceb1679b501414b996c520b08ce929a40f94c (diff)
downloadhaskell-8b422142421c751d2c7fa7840afa61f923afdbe1.tar.gz
Tweak use of AC_USE_SYSTEM_EXTENSIONS
This makes sure that `AC_USE_SYSTEM_EXTENSIONS` (which implies `AC_PROG_CC`) is called after the `AC_ARG_WITH([cc],,)` invocation, so that the proper CC setting is in scope. Otherwise this can break cross-compilation. This also needs to pull in a submodule update for `unix` This is a follow-up commit to 7af29da05d2e5a5e311a5f73f20d0f232035973b which hopefully fixes #11168
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 57d877ab58..c8708ae7db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,9 +58,6 @@ dnl #define SIZEOF_CHAR 0
dnl recently.
AC_PREREQ([2.60])
-dnl make extensions visible to allow feature-tests to detect them lateron
-AC_USE_SYSTEM_EXTENSIONS
-
# -------------------------------------------------------------------------
# Prepare to generate the following header files
#
@@ -462,6 +459,9 @@ export CC
MAYBE_OVERRIDE_STAGE0([gcc],[CC_STAGE0])
MAYBE_OVERRIDE_STAGE0([ar],[AR_STAGE0])
+dnl make extensions visible to allow feature-tests to detect them lateron
+AC_USE_SYSTEM_EXTENSIONS
+
dnl ** figure out how to invoke the C preprocessor (i.e. `gcc -E`)
AC_PROG_CPP