summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Marlow <marlowsd@gmail.com>2013-01-25 20:50:43 +0000
committerSimon Marlow <marlowsd@gmail.com>2013-01-25 20:54:58 +0000
commit351a8c6bbd53ce07d687b5a96afff77c4c9910cc (patch)
tree2c7f4a5b7750bd1dd2d60fe248f3b13f60f87362 /configure.ac
parent48a96bdbec81d9db527b6b4ad637a630508f3561 (diff)
downloadhaskell-351a8c6bbd53ce07d687b5a96afff77c4c9910cc.tar.gz
fix ARM hard float "detection"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 97592e262d..02f327fb6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -211,11 +211,11 @@ AC_CANONICAL_TARGET
# required for code generation (LLVM options)
ARM_ABI=SOFT
-case $host in
- arm*-*-linux-gnueabihf)
+case $target in
+ arm*-*-linux-gnueabihf | arm*-linux-gnueabihf)
ARM_ABI=HARD
;;
- arm*-*-linux-gnueabi)
+ arm*-*-linux-gnueabi | arm*-linux-gnueabi)
ARM_ABI=SOFTFP
;;
esac