summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAustin Seipp <austin@well-typed.com>2014-08-19 06:36:02 -0500
committerAustin Seipp <austin@well-typed.com>2014-08-19 06:36:03 -0500
commit527bcc41630918977c73584d99125ff164400695 (patch)
treede154ca063e2672e432a43a74452b312f2029006 /configure.ac
parent2fc22949e30eab9f751be90e788ebb2b56f1b132 (diff)
downloadhaskell-527bcc41630918977c73584d99125ff164400695.tar.gz
build: require GHC 7.6 for bootstrapping
Summary: Per the usual standards, a build of GHC is only compileable by the last two releases (e.g. 7.8 only by 7.4 and 7.6). To make sure we don't get suckered into supporting older compilers, let's remove this support now. Signed-off-by: Austin Seipp <austin@well-typed.com> Test Plan: Try to bootstrap with GHC 7.4, watch it fail. Bootstrap with 7.6 or better, and everything works. Reviewers: hvr Reviewed By: hvr Subscribers: simonmar, ezyang, carter Differential Revision: https://phabricator.haskell.org/D167
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 1c72cfa3c2..9e31c52f78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,8 +136,8 @@ if test "$WithGhc" = ""
then
AC_MSG_ERROR([GHC is required.])
fi
-FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[7.4],
- [AC_MSG_ERROR([GHC version 7.4 or later is required to compile GHC.])])dnl
+FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[7.6],
+ [AC_MSG_ERROR([GHC version 7.6 or later is required to compile GHC.])])
if test `expr $GhcMinVersion % 2` = "1"
then
@@ -151,9 +151,7 @@ then
fi
fi
-FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[7.5],
- GHC_PACKAGE_DB_FLAG=package-conf,
- GHC_PACKAGE_DB_FLAG=package-db)
+GHC_PACKAGE_DB_FLAG=package-db
AC_SUBST(GHC_PACKAGE_DB_FLAG)
# GHC 7.7+ needs -fcmm-sink when compiling Parser.hs. See #8182