summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-08-05 17:44:49 +0300
committerSergei Trofimovich <slyfox@gentoo.org>2014-08-05 17:44:49 +0300
commit7479df6af5dd7bc72158d7617dab5c5f139a87fb (patch)
tree197df09d9db22283e6fa4a2a2ecab1d684344361 /configure.ac
parent94b2b22582f1584a4007b4301dbe7070589d951f (diff)
downloadhaskell-7479df6af5dd7bc72158d7617dab5c5f139a87fb.tar.gz
configure.ac: drop unused VOID_INT_SIGNALS
Summary: Another macro borrowed from hugs, gone aways in commit 528a7d2cf1c90408d60028bb1fec85124d539476 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Test Plan: build-tested Reviewers: simonmar, austin, ezyang Reviewed By: austin, ezyang Subscribers: phaskell, simonmar, relrod, ezyang, carter Differential Revision: https://phabricator.haskell.org/D118
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 1 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 5fc5733bb4..d9524287dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,7 +228,7 @@ case $host in
# here we go with the test
MINOR=`uname -r|cut -d '.' -f 2-`
if test "$MINOR" -lt "11"; then
- SOLARIS_BROKEN_SHLD=YES
+ SOLARIS_BROKEN_SHLD=YES
fi
;;
esac
@@ -818,30 +818,6 @@ FP_CHECK_FUNC([WinExec],
FP_CHECK_FUNC([GetModuleFileName],
[@%:@include <windows.h>], [GetModuleFileName((HMODULE)0,(LPTSTR)0,0)])
-dnl ** check return type of signal handlers
-dnl Foo: assumes we can use prototypes.
-dnl On BCC, signal handlers have type "int(void)", elsewhere its "void(int)".
-dnl AC_CACHE_CHECK([type of signal handlers], ac_cv_type_signal_handler,
-dnl [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>
-dnl #include <signal.h>
-dnl #ifdef signal
-dnl #undef signal
-dnl #endif
-dnl void (*signal (int, void (*)(int)))(int);
-dnl ]],
-dnl [[int i;]])],
-dnl [ac_cv_type_signal_handler=void_int],
-dnl [ac_cv_type_signal_handler=int_void])])
-dnl if test "$ac_cv_type_signal_handler" = void_int; then
-dnl AC_DEFINE(VOID_INT_SIGNALS)
-dnl fi
-
-dnl On BCC, signal handlers have type "int(void)", elsewhere its "void(int)".
-AC_TYPE_SIGNAL
-if test "$ac_cv_type_signal" = void; then
- AC_DEFINE([VOID_INT_SIGNALS], [1], [Define to 1 if signal handlers have type void (*)(int). Otherwise, they're assumed to have type int (*)(void).])
-fi
-
dnl ** check for more functions
dnl ** The following have been verified to be used in ghc/, but might be used somewhere else, too.
AC_CHECK_FUNCS([getclock getrusage gettimeofday setitimer siginterrupt sysconf times ctime_r sched_setaffinity setlocale])