summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGHC GitLab CI <ghc-ci@gitlab-haskell.org>2020-08-09 09:35:47 -0400
committerMarge Bot <ben+marge-bot@smart-cactus.org>2020-09-04 22:26:25 -0400
commit07bdcac38c90e79db9e4327f87c5400630dfe74b (patch)
treef8a20b2a435bc58c03356efd293fe939ddb9b58f /configure.ac
parentc1e54439be3d38a1f972ac772cca7eec5e1519a9 (diff)
downloadhaskell-07bdcac38c90e79db9e4327f87c5400630dfe74b.tar.gz
configure: Avoid hard-coded ld path on Windows
The fix to #17962 ended up regressing on Windows as it failed to replicate the logic responsible for overriding the toolchain paths on Windows. This resulted in a hard-coded path to a directory that likely doesn't exist on the user's system (#18550).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5e3dfa5470..f080b296bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -449,6 +449,8 @@ then
NM="${mingwbin}nm.exe"
RANLIB="${mingwbin}ranlib.exe"
OBJDUMP="${mingwbin}objdump.exe"
+ MergeObjsCmd="$LD"
+ MergeObjsArgs="-r --oformat=pe-bigobj-x86-64"
fp_prog_ar="${mingwbin}ar.exe"
AC_PATH_PROG([Genlib],[genlib])