summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTamar Christina <tamar@zhox.com>2019-06-02 14:55:34 +0100
committerBen Gamari <ben@smart-cactus.org>2020-07-15 16:41:01 -0400
commit71245fcce24723910f12f934fbc4c700658b727a (patch)
tree83d387775893a72afc97cb73b345864f77b1bf98 /configure.ac
parent90e69f779b6da755fac472337535a1321cbb7917 (diff)
downloadhaskell-71245fcce24723910f12f934fbc4c700658b727a.tar.gz
winio: Add new io-manager cmdline options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6e710c7f8d..d3ef6eee62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,6 +117,18 @@ if test "$EnableDistroToolchain" = "YES"; then
TarballsAutodownload=NO
fi
+AC_ARG_ENABLE(native-io-manager,
+[AC_HELP_STRING([--enable-native-io-manager],
+ [Enable the native I/O manager by default.])],
+ EnableNativeIOManager=YES,
+ EnableNativeIOManager=NO
+)
+
+if test "$EnableNativeIOManager" = "YES"; then
+ AC_DEFINE_UNQUOTED([DEFAULT_NATIVE_IO_MANAGER], [1], [Enable Native I/O manager as default.])
+
+fi
+
dnl CC_STAGE0, LD_STAGE0, AR_STAGE0 are like the "previous" variable
dnl CC, LD, AR (inherited by CC_STAGE[123], etc.)
dnl but instead used by stage0 for bootstrapping stage1