summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Schulze Frielinghaus <stefansf@linux.ibm.com>2020-07-23 11:04:23 +0200
committerMarge Bot <ben+marge-bot@smart-cactus.org>2020-07-25 00:45:45 -0400
commitfc0f6fbcd95f2dc69a8efabbee2d8a485c34cc47 (patch)
tree44b8b8d161d373802f5c664080c9abfb9f13ca7a /configure.ac
parent6e2db34bdfead7ad309d8fd01d4423554650cf4c (diff)
downloadhaskell-fc0f6fbcd95f2dc69a8efabbee2d8a485c34cc47.tar.gz
Require SMP support in order to build a threaded stage1
Fixes 18266
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d3ef6eee62..150c0cdb82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,13 +166,17 @@ if test "$WithGhc" != ""; then
fi
BOOTSTRAPPING_GHC_INFO_FIELD([AR_OPTS_STAGE0],[ar flags])
BOOTSTRAPPING_GHC_INFO_FIELD([ArSupportsAtFile_STAGE0],[ar supports at file])
+ BOOTSTRAPPING_GHC_INFO_FIELD([SUPPORT_SMP_STAGE0],[Support SMP])
BOOTSTRAPPING_GHC_INFO_FIELD([RTS_WAYS_STAGE0],[RTS ways])
dnl Check whether or not the bootstrapping GHC has a threaded RTS. This
dnl determines whether or not we can have a threaded stage 1.
dnl See Note [Linking ghc-bin against threaded stage0 RTS] in
dnl hadrian/src/Settings/Packages.hs for details.
- if echo ${RTS_WAYS_STAGE0} | grep '.*thr.*' 2>&1 >/dev/null; then
+ dnl SMP support which implies a registerised stage0 is also required (see issue 18266)
+ if echo ${RTS_WAYS_STAGE0} | grep '.*thr.*' 2>&1 >/dev/null && \
+ test "$SUPPORT_SMP_STAGE0" = "YES"
+ then
AC_SUBST(GhcThreadedRts, YES)
else
AC_SUBST(GhcThreadedRts, NO)