summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2008-07-03 13:26:14 +0000
committerIan Lynagh <igloo@earth.li>2008-07-03 13:26:14 +0000
commit5ed560ba64842f909a26a000f9eaa965b80f696e (patch)
tree06a90064143402f6e414b3adb394c78cae6759c2 /configure.ac
parentcf071813ab8d7edd8ca92a2191812a96e9cb20f0 (diff)
downloadhaskell-5ed560ba64842f909a26a000f9eaa965b80f696e.tar.gz
Shove the GHC path through cygpath -m
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f22ffbe571..8645834d50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -644,6 +644,14 @@ AC_ARG_WITH([ghc],
AC_PATH_PROG([GHC], [ghc])
fi
WithGhc="$GHC"])
+# GHC is passed to Cabal, so we need a native path
+if test "x$HostPlatform" = "xi386-unknown-mingw32" && \
+ test "${OSTYPE}" != "msys" && \
+ test "${WithGhc}" != ""
+then
+ # Canonicalise to <drive>:/path/to/ghc
+ WithGhc=`cygpath -m ${WithGhc}`
+fi
AC_SUBST([WithGhc])
AC_ARG_WITH(hc,