summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlec Theriault <alec.theriault@gmail.com>2018-12-07 23:18:15 -0500
committerBen Gamari <ben@smart-cactus.org>2018-12-07 23:18:16 -0500
commitcb882fc993b4972f7f212b291229ef9e9ade0af9 (patch)
treeb36cd838f6eb1ee357ac0d118ee367b19f43aa3d /configure.ac
parentbd80831610092fef2f540abe9725e177c1ef0df8 (diff)
downloadhaskell-cb882fc993b4972f7f212b291229ef9e9ade0af9.tar.gz
Require 'libdw' for '--enable-dwarf-unwind'
This causes './configure --enable-dwarf-unwind' to exit with a helpful error message when 'libdw' cannot be found (compared to the previous behaviour of silently pretending the user hadn't requested DWARF support at all). Test Plan: ./configure --enable-dwarf-unwind # on systems with/without libdw Reviewers: bgamari, nh2 Reviewed By: nh2 Subscribers: nh2, rwbarton, erikd, carter GHC Trac Issues: #15968 Differential Revision: https://phabricator.haskell.org/D5424
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 88eddca097..2cf98a79dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1248,7 +1248,9 @@ USE_LIBDW=0
AC_ARG_ENABLE(dwarf-unwind,
[AC_HELP_STRING([--enable-dwarf-unwind],
[Enable DWARF unwinding support in the runtime system via elfutils' libdw [default=no]])],
- [AC_CHECK_LIB(dw, dwfl_attach_state, [UseLibdw=YES], [UseLibdw=NO])],
+ [AC_CHECK_LIB(dw, dwfl_attach_state,
+ [UseLibdw=YES],
+ [AC_MSG_ERROR([Cannot find system libdw (required by --enable-dwarf-unwind)])])]
[UseLibdw=NO]
)
AC_SUBST(UseLibdw)