summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2018-11-26 17:21:12 -0500
committerMarge Bot <ben+marge-bot@smart-cactus.org>2019-03-05 22:22:40 -0500
commit37f257afcd6a52cf4d76c60d766b1aeb520b9f05 (patch)
treeac800e46fbf94c16ce39170f4a720637b07dde06 /configure.ac
parent646b6dfbe125aa756a935e840979ba11b4a882c0 (diff)
downloadhaskell-37f257afcd6a52cf4d76c60d766b1aeb520b9f05.tar.gz
Rip out object splitting
The splitter is an evil Perl script that processes assembler code. Its job can be done better by the linker's --gc-sections flag. GHC passes this flag to the linker whenever -split-sections is passed on the command line. This is based on @DemiMarie's D2768. Fixes Trac #11315 Fixes Trac #9832 Fixes Trac #8964 Fixes Trac #8685 Fixes Trac #8629
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 0 insertions, 45 deletions
diff --git a/configure.ac b/configure.ac
index 1aae46526e..a803a1faed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -386,20 +386,6 @@ then
fp_prog_ar="${mingwbin}ar.exe"
AC_PATH_PROG([Genlib],[genlib])
-
- # NB. Download the perl binaries if required
- if ! test -d inplace/perl ||
- test inplace/perl -ot ghc-tarballs/perl/ghc-perl*.tar.gz
- then
- AC_MSG_NOTICE([Making in-tree perl tree])
- rm -rf inplace/perl
- mkdir inplace/perl
- (
- cd inplace/perl &&
- tar -zxf ../../ghc-tarballs/perl/ghc-perl*.tar.gz
- )
- AC_MSG_NOTICE([In-tree perl tree created])
- fi
fi
# We don't want to bundle a MinGW-w64 toolchain
@@ -696,36 +682,6 @@ AC_SUBST([GhcLibsWithUnix])
dnl ** does #! work?
AC_SYS_INTERPRETER()
-# Check for split-objs
-SplitObjsBroken=NO
-dnl ** look for `perl'
-case $HostOS_CPP in
-cygwin32|mingw32)
- if test "$EnableDistroToolchain" = "NO"; then
- PerlCmd=$hardtop/inplace/perl/perl
- else
- AC_PATH_PROG([PerlCmd],[perl])
- fi
- # because of Trac #15051 SplitObjs is useless on Windows. It regresses
- # build times to days for a build, and this effect is also there for end users
- # of GHC. So unfortunately we have to disable it, even without having
- # split-sections. Though the compile time hit for split-sections should be
- # tiny compared to this so maybe we should enable it for x86_64.
- SplitObjsBroken=YES
- ;;
-*)
- AC_PATH_PROG([PerlCmd],[perl])
- if test -z "$PerlCmd"
- then
- AC_MSG_WARN([No Perl on PATH, disabling split object support])
- SplitObjsBroken=YES
- else
- FPTOOLS_CHECK_PERL_VERSION
- fi
- ;;
-esac
-AC_SUBST([SplitObjsBroken])
-
dnl ** look for GCC and find out which version
dnl Figure out which C compiler to use. Gcc is preferred.
dnl If gcc, make sure it's at least 3.0
@@ -1391,7 +1347,6 @@ echo "\
genlib : $GenlibCmd
Happy : $HappyCmd ($HappyVersion)
Alex : $AlexCmd ($AlexVersion)
- Perl : $PerlCmd
sphinx-build : $SPHINXBUILD
xelatex : $XELATEX