summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <bgamari.foss@gmail.com>2017-09-25 18:41:23 -0400
committerBen Gamari <ben@smart-cactus.org>2017-09-25 22:43:52 -0400
commit65f7d87a9bd43a6dfc077fbcb8781de07dd335c1 (patch)
tree1d27d4410e86990d069b8c50d5eda266245a09dd /configure.ac
parent49c1a20dbbdabc8101877e8ef2c8de9ec3a079d0 (diff)
downloadhaskell-65f7d87a9bd43a6dfc077fbcb8781de07dd335c1.tar.gz
configure: Don't hard-code strip tool
For reasons that I don't entirely understand we didn't previously detect `strip` using autoconf. This naturally broke during cross-compilation. How did this ever work? I have no idea. Test Plan: Try cross-compiling Reviewers: austin, hvr, angerman Subscribers: rwbarton, thomie, erikd Differential Revision: https://phabricator.haskell.org/D4008
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5eae83db96..009bea0c58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -605,6 +605,13 @@ fi
RanlibCmd="$RANLIB"
RANLIB="$RanlibCmd"
+dnl ** which strip to use?
+dnl --------------------------------------------------------------
+AC_CHECK_TARGET_TOOL([STRIP], [strip])
+StripCmd="$STRIP"
+AC_SUBST([StripCmd])
+
+
dnl ** which libtool to use?
dnl --------------------------------------------------------------
# The host normalization on Windows breaks autoconf, it no longer