summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2009-11-20 15:39:53 +0000
committerIan Lynagh <igloo@earth.li>2009-11-20 15:39:53 +0000
commit4bd031279103a2772ac1673e1dcf3c9d67655242 (patch)
tree322143e8c33a806490d4d52c105078e1fa04e513 /configure.ac
parentabd0df2e11c3ba15a141de16f1d982c63113a3fe (diff)
downloadhaskell-4bd031279103a2772ac1673e1dcf3c9d67655242.tar.gz
Use the ghc-perl tarball on Windows, instead of the msys one
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index aa333f6073..29afd29d56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -405,14 +405,25 @@ then
tar -zxf ../../ghc-tarballs/mingw/gcc-core*.tar.gz &&
tar -jxf ../../ghc-tarballs/mingw/libcrypt*.tar.bz2 &&
tar -zxf ../../ghc-tarballs/mingw/mingw-runtime*.tar.gz &&
- tar -zxf ../../ghc-tarballs/mingw/msysCORE*.tar.gz &&
- tar -jxf ../../ghc-tarballs/mingw/perl*.tar.bz2 &&
tar -zxf ../../ghc-tarballs/mingw/w32api*.tar.gz &&
mv bin/gcc.exe bin/realgcc.exe
)
inplace/mingw/bin/realgcc.exe driver/gcc/gcc.c driver/utils/getLocation.c -Idriver/utils -o inplace/mingw/bin/gcc.exe
AC_MSG_NOTICE([In-tree mingw tree created])
fi
+ if ! test -d inplace/perl ||
+ test inplace/perl -ot ghc-tarballs/perl/ghc-perl*.tar.gz
+ then
+ AC_MSG_NOTICE([Making in-tree perl tree])
+ rm -rf inplace/perl
+ mkdir inplace
+ mkdir inplace/perl
+ (
+ cd inplace/perl &&
+ tar -zxf ../../ghc-tarballs/perl/ghc-perl*.tar.gz
+ )
+ AC_MSG_NOTICE([In-tree perl tree created])
+ fi
fi
dnl ** Which gcc to use?