summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Kilian <kili@outback.escape.de>2009-08-26 15:59:13 +0000
committerMatthias Kilian <kili@outback.escape.de>2009-08-26 15:59:13 +0000
commitacdd7c95066cf6505a4d2e8683f119146805af91 (patch)
tree2b2d3cd4a23f8c5c7252370db272d127dec79168 /configure.ac
parentd84757e30d8578aaa788c26f0245c67ab482d0f9 (diff)
downloadhaskell-acdd7c95066cf6505a4d2e8683f119146805af91.tar.gz
Configurable iconv header and library locations
Should help to fix the build on OpenBSD (together with a corresponding patch to libraries/base).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14d8710c07..41e6c3f9f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -193,6 +193,25 @@ AC_SUBST([WithGhc])
dnl ** Without optimization some INLINE trickery fails for GHCi
SRC_CC_OPTS="-O"
+dnl Allow to specify iconv options to the toplevel configure script
+dnl so they can be properly passed to sub-builds.
+dnl Note: ICONV_LIB_DIRS and ICONV_INCLUDE_DIRS are not predefined
+dnl to the empty string to allow them to be overridden from the
+dnl environment.
+
+AC_ARG_WITH([iconv-includes],
+ [AC_HELP_STRING([--with-iconv-includes],
+ [directory containing iconv.h])],
+ [ICONV_INCLUDE_DIRS=$withval])
+
+AC_ARG_WITH([iconv-libraries],
+ [AC_HELP_STRING([--with-iconv-libraries],
+ [directory containing iconv library])],
+ [ICONV_LIB_DIRS=$withval])
+
+AC_SUBST(ICONV_INCLUDE_DIRS)
+AC_SUBST(ICONV_LIB_DIRS)
+
dnl--------------------------------------------------------------------
dnl * Choose host(/target/build) platform
dnl--------------------------------------------------------------------