summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <ian@well-typed.com>2012-11-13 21:43:18 +0000
committerIan Lynagh <ian@well-typed.com>2012-11-13 21:43:18 +0000
commite40793555656552fe5ee6a6227ab60f379bea4b8 (patch)
tree0381166e21797f7c668d3976884807b95a42b688 /configure.ac
parent7ea49661cc5b45b048aca9a45f7fe3616fb56228 (diff)
downloadhaskell-e40793555656552fe5ee6a6227ab60f379bea4b8.tar.gz
Remove the HAVE_SETITIMER_VIRTUAL configure test
We no longer actually use ITIMER_VIRTUAL anyway
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 4ca64f2714..5c887f61ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -779,20 +779,6 @@ dnl ** check for more functions
dnl ** The following have been verified to be used in ghc/, but might be used somewhere else, too.
AC_CHECK_FUNCS([getclock getrusage gettimeofday setitimer siginterrupt sysconf times ctime_r sched_setaffinity setlocale])
-if test "$cross_compiling" = "no" ; then
- AC_TRY_RUN([
- #include <sys/types.h>
- #include <sys/time.h>
- int main(void) {
- struct itimerval tval;
- tval.it_value.tv_sec = 1;
- tval.it_value.tv_usec = 0;
- tval.it_interval = tval.it_value;
- return setitimer(ITIMER_VIRTUAL, &tval, (void*)0) != 0;
- }
- ],[AC_DEFINE([HAVE_SETITIMER_VIRTUAL], [1], [Define to 1 if setitimer accepts ITIMER_VIRTUAL, 0 else.])])
-fi
-
dnl ** On OS X 10.4 (at least), time.h doesn't declare ctime_r if
dnl ** _POSIX_C_SOURCE is defined
AC_CHECK_DECLS([ctime_r], , ,