summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorManuel M T Chakravarty <chak@cse.unsw.edu.au>2012-04-21 17:43:34 +1000
committerManuel M T Chakravarty <chak@cse.unsw.edu.au>2012-04-21 17:43:34 +1000
commit24746fe78024a1edab843bc710c79c55998ab134 (patch)
tree004d0a54b6c59eef250b42ed5cc3f4410d436ee3 /configure.ac
parent82298011eda2a56f4bfe288a26cb5c0807e90fb6 (diff)
downloadhaskell-24746fe78024a1edab843bc710c79c55998ab134.tar.gz
OS X: disable bootstrapping info for 'ar'
Xcode 4.3 installs the command line tools in a different location as earlier versions of Xcode. With the bootstrapping info, the build fails if the bootstrap compiler was built with an older version of Xcode.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b796f6d441..9237c771d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,10 +131,17 @@ if test "$WithGhc" != ""; then
GhcMinVersion2=`echo "$GhcMinVersion" | sed 's/^\\(.\\)$/0\\1/'`
GhcCanonVersion="$GhcMajVersion$GhcMinVersion2"
+ BOOTSTRAPPING_GHC_INFO_FIELD([OS_STAGE0],[target os],['unkown'])
BOOTSTRAPPING_GHC_INFO_FIELD([CC_STAGE0],[C compiler command],['$(CC)'])
- BOOTSTRAPPING_GHC_INFO_FIELD([AR_STAGE0],[ar command],['$(AR)'])
- BOOTSTRAPPING_GHC_INFO_FIELD([AR_OPTS_STAGE0],[ar flags],['$(AR_OPTS)'])
- BOOTSTRAPPING_GHC_INFO_FIELD([ArSupportsAtFile_STAGE0],[ar supports at file],['$(ArSupportsAtFile)'])
+ if test "x$OS_STAGE0" != "xOSDarwin"; then
+ BOOTSTRAPPING_GHC_INFO_FIELD([AR_STAGE0],[ar command],['$(AR)'])
+ BOOTSTRAPPING_GHC_INFO_FIELD([AR_OPTS_STAGE0],[ar flags],['$(AR_OPTS)'])
+ BOOTSTRAPPING_GHC_INFO_FIELD([ArSupportsAtFile_STAGE0],[ar supports at file],['$(ArSupportsAtFile)'])
+ else
+ AR_STAGE0='$(AR)'
+ AR_OPTS_STAGE0='$(AR_OPTS)'
+ ArSupportsAtFile_STAGE0='$(ArSupportsAtFile)'
+ fi
fi
dnl ** Must have GHC to build GHC, unless --enable-hc-boot is on