summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Gardas <karel.gardas@centrum.cz>2015-10-31 23:16:53 +0100
committerKarel Gardas <karel.gardas@centrum.cz>2015-10-31 23:19:34 +0100
commitbc7cc25676a8edd7be8cab30d4f26b3dd064f717 (patch)
tree18d754dcdf5d38a3f249efd94d775920d178e86a /configure.ac
parent8f02baac9ea3d8cf8dfbadd2bc3af799ddbc0367 (diff)
downloadhaskell-bc7cc25676a8edd7be8cab30d4f26b3dd064f717.tar.gz
disable large address space on OpenBSD
Summary: This patch disables large address space on OpenBSD. The motivation for this is that OpenBSD does not support MAP_NORESERVE. The flag is supported only for source code compatibility reasons but is otherwise completely ignored by the OS and its mmap syscall. Reviewers: austin, bgamari Subscribers: thomie, erikd Differential Revision: https://phabricator.haskell.org/D1411
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65e5d77829..bc18c124cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1046,6 +1046,11 @@ if test "$ac_cv_sizeof_void_p" -eq 8 ; then
if test "x$EnableLargeAddressSpace" = "xyes" ; then
if test "$ghc_host_os" = "darwin" ; then
use_large_address_space=yes
+ elif test "$ghc_host_os" = "openbsd" ; then
+ # as of OpenBSD 5.8 (2015), OpenBSD does not support mmap with MAP_NORESERVE.
+ # The flag MAP_NORESERVE is supported for source compatibility reasons,
+ # but is completely ignored by OS mmap
+ use_large_address_space=no
else
AC_CHECK_DECLS([MAP_NORESERVE, MADV_FREE, MADV_DONTNEED],[],[],
[