summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Gardas <karel.gardas@centrum.cz>2012-04-25 09:04:50 +0200
committerSimon Marlow <marlowsd@gmail.com>2012-04-27 11:13:06 +0100
commit3144f85661da176e3d80f28d652b42245becde09 (patch)
treef10ab746a7cf379e134960ca7daaa2c14643a46e /configure.ac
parent18c2a2f71e38fad5e677b8f448f6135e5a691868 (diff)
downloadhaskell-3144f85661da176e3d80f28d652b42245becde09.tar.gz
add support for ARM hard-float ABI (fixes #5914)
This patch enhances Platform's ArchARM to include ARM ABI value. It also tweaks configure machinery to detect hard-float ABI and to set it wherever needed. Finally when hard-float ABI is in use, pass appropriate compiler option to the LLVM's llc. Fixes #5914.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9237c771d3..8e3d9d2837 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,6 +210,20 @@ AC_CANONICAL_BUILD
AC_CANONICAL_HOST
AC_CANONICAL_TARGET
+# Testing ARM ABI
+# required for code generation (LLVM options)
+ARM_ABI=SOFT
+echo HOST: $host
+
+case $host in
+ arm*-*-linux-gnueabihf)
+ ARM_ABI=HARD
+ ;;
+ arm*-*-linux-gnueabi)
+ ARM_ABI=SOFTFP
+ ;;
+esac
+
FPTOOLS_SET_PLATFORM_VARS
# Verify that the installed (bootstrap) GHC is capable of generating