summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2018-09-19 15:23:27 -0400
committerBen Gamari <ben@smart-cactus.org>2018-09-20 10:13:55 -0400
commitd7fa8695324d6e0c3ea77228f9de93d529afc23e (patch)
tree7b9f23449b7c8bbc1ebe9c23dcaf831f2d3f1824 /configure.ac
parentba086ca72ee6c77abba685f3100ad513e38a1a87 (diff)
downloadhaskell-d7fa8695324d6e0c3ea77228f9de93d529afc23e.tar.gz
Revert "adds -latomic to. ghc-prim"
This commit was never properly justified and relies on the existence of libatomic, which doesn't appear to exist on Darwin. This reverts commit ec9aacf3eb2975fd302609163aaef429962ecd87.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b05535e20..f7943752cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -739,6 +739,11 @@ FP_GCC_VERSION
dnl ** See whether gcc supports -no-pie
FP_GCC_SUPPORTS_NO_PIE
+dnl ** Used to determine how to compile ghc-prim's atomics.c, used by
+dnl unregisterised, Sparc, and PPC backends.
+FP_GCC_SUPPORTS__ATOMICS
+AC_DEFINE([HAVE_C11_ATOMICS], [$CONF_GCC_SUPPORTS__ATOMICS], [Does GCC support __atomic primitives?])
+
FP_GCC_EXTRA_FLAGS
dnl ** look to see if we have a C compiler using an llvm back end.