summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZubin Duggal <zubin.duggal@gmail.com>2021-06-17 16:25:46 +0530
committerMarge Bot <ben+marge-bot@smart-cactus.org>2021-06-20 07:13:07 -0400
commit6c783817ef089e85642c3383937117cff9d15f67 (patch)
tree90266d7337b67a7703c88db0a9a668c19f02ff2f /configure.ac
parent4a65c0f88060785a8bcb25bb13bc53c20948633b (diff)
downloadhaskell-6c783817ef089e85642c3383937117cff9d15f67.tar.gz
Set min LLVM version to 9 and make version checking use a non-inclusive upper
bound. We use a non-inclusive upper bound so that setting the upper bound to 13 for example means that all 12.x versions are accepted.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e3763055ec..38de5953b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -724,8 +724,8 @@ AC_SUBST(InstallNameToolCmd)
# tools we are looking for. In the past, GHC supported a number of
# versions of LLVM simultaneously, but that stopped working around
# 3.5/3.6 release of LLVM.
-LlvmMinVersion=10
-LlvmMaxVersion=12 # inclusive
+LlvmMinVersion=9 # inclusive
+LlvmMaxVersion=13 # not inclusive
AC_SUBST([LlvmMinVersion])
AC_SUBST([LlvmMaxVersion])
sUPPORTED_LLVM_VERSION_MIN=$(echo \($LlvmMinVersion\) | sed 's/\./,/')