summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2021-05-05 13:11:33 -0400
committerMarge Bot <ben+marge-bot@smart-cactus.org>2021-05-06 12:45:19 -0400
commit30f6923a834ccaca30c3622a0a82421fabcab119 (patch)
treeb0cee6f3aa869e652d409963bdf9bec005ade5d8 /configure.ac
parent0281dae8b3fe3384939c415ae72ca2440b3cafb3 (diff)
downloadhaskell-30f6923a834ccaca30c3622a0a82421fabcab119.tar.gz
hadrian: Don't depend upon bash from PATH
Previously Hadrian depended implicitly upon whatever `bash` it found in `PATH`, offerring no way for the user to override. Fix this by detecting `sh` in `configure` and passing the result to Hadrian. Fixes #19797.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5582c9fb2f..e3763055ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,6 +255,8 @@ AC_CANONICAL_TARGET
FPTOOLS_SET_PLATFORM_VARS
+FP_PROG_SH
+
# Verify that the installed (bootstrap) GHC is capable of generating
# code for the requested build platform.
if test "$BuildPlatform" != "$bootstrap_target"