summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Marlow <simonmar@microsoft.com>2007-02-06 21:25:36 +0000
committerSimon Marlow <simonmar@microsoft.com>2007-02-06 21:25:36 +0000
commit06decfcd62d1ca9069cd4707115ecb92bea39064 (patch)
tree040c7bca94a80fc3acc735c19597c55ca0f7bc5f /configure.ac
parente975c8f09ac8d85059a4b42cf56ebe036aa95dc7 (diff)
downloadhaskell-06decfcd62d1ca9069cd4707115ecb92bea39064.tar.gz
Detect the snapshot version number using darcs
For non-release builds, we want to append a date to the version number (e.g. 6.7.20070206). Previously this was done by the nightly build script, this new method figures out the snapshot version by querying the darcs repository and finding the date of the most recent patch (actually it finds the most recent of the last 100 patches, but that should be good enough). This is done by the configure script. To handle source distributions, we create a file VERSION in the top-level directory that contains the version number, and ship this in the source distribution. The configure script picks up the version from this file if it doesn't see a _darcs directory.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index eb64f4e853..a1a9861b82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,9 +3,9 @@ dnl (run "grep '^dnl \*' configure.ac | sed -e 's/dnl / /g; s/\*\*/ +/g;'"
dnl (or some such) to see the outline of this file)
dnl
#
-# (c) The AQUA Project, Glasgow University, 1994-2004
+# (c) The University of Glasgow 1994-2004
#
-# Configure script template for the Glasgow functional programming tools
+# Configure script template for GHC
#
# Process with 'autoreconf' to get a working configure script.
#
@@ -15,6 +15,17 @@ dnl
AC_INIT([The Glorious Glasgow Haskell Compilation System], [6.7], [glasgow-haskell-bugs@haskell.org], [ghc])
+# Set this to YES for a released version, otherwise NO
+RELEASE=NO
+
+# The primary version (e.g. 6.7, 6.6.1) is set in the AC_INIT line
+# above. If this is not a released version, then we will append the
+# date to the version number (e.g. 6.7.20070204). The date is
+# constructed by finding the date of the most recent patch in the
+# darcs repository. If this is a source distribution (not a darcs
+# checkout), then we ship a file 'VERSION' containing the full version
+# when the source distribution was created.
+
if test ! -f mk/config.h.in; then
echo "mk/config.h.in doesn't exist: perhaps you haven't run 'autoreconf'?"
exit 1