summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2007-03-11 17:50:25 +0000
committerIan Lynagh <igloo@earth.li>2007-03-11 17:50:25 +0000
commitca5ded310c0a596be199a3da5f14be2fb2020687 (patch)
tree40a62ff03dc093e157fbec315cef60be4fb78a66 /configure.ac
parent642ac8a05ea7f449c367cd4293b0e07ca3305fd8 (diff)
downloadhaskell-ca5ded310c0a596be199a3da5f14be2fb2020687.tar.gz
Have configure take arguments telling it where gmp is; fixes trac #957
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5ce9210d49..39856a2caa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,25 @@ if test x"$srcdir" != 'x.' ; then
fi
dnl--------------------------------------------------------------------
+dnl * Deal with arguments telling us gmp is somewhere odd
+dnl--------------------------------------------------------------------
+
+FP_ARG_GMP
+
+GMP_INCLUDE_DIRS=
+GMP_LIB_DIRS=
+if test "x$gmp_libraries" != "xNONE"; then
+ LDFLAGS="-L$gmp_libraries $LDFLAGS"
+ GMP_LIB_DIRS=$gmp_libraries
+fi
+if test "x$gmp_includes" != "xNONE"; then
+ CPPFLAGS="-I$gmp_includes $CPPFLAGS"
+ GMP_INCLUDE_DIRS=$gmp_includes
+fi
+AC_SUBST(GMP_INCLUDE_DIRS)
+AC_SUBST(GMP_LIB_DIRS)
+
+dnl--------------------------------------------------------------------
dnl * Choose host(/target/build) platform
dnl--------------------------------------------------------------------