summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorViktor Dukhovni <ietf-dane@dukhovni.org>2021-04-19 04:02:33 -0400
committerMarge Bot <ben+marge-bot@smart-cactus.org>2021-04-22 17:00:55 -0400
commitaa685c50d575ccf6c46a89d4ecdc9cffcf8b73f4 (patch)
tree29bd281a842b6dd355222c46cd866d61fee7b9e6 /configure.ac
parent350f4f61ae847c8adf376b9ca49ad1fee64e2e95 (diff)
downloadhaskell-aa685c50d575ccf6c46a89d4ecdc9cffcf8b73f4.tar.gz
Add background note in elf_tlsgd.c.
Also some code cleanup, and a fix for an (extant unrelated) missing <pthread_np.h> include that should hopefully resolve a failure in the FreeBSD CI build, since it is best to make sure that this MR actually builds on FreeBSD systems other than mine. Some unexpected metric changes on FreeBSD (perhaps because CI had been failing for a while???): Metric Decrease: T3064 T5321Fun T5642 T9020 T12227 T13253-spj T15164 T18282 WWRec Metric Increase: haddock.compiler
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f414308ae8..013f21f3ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1219,6 +1219,8 @@ dnl ~~~~~~~~~~~~~~~~~~~~
dnl The portability situation here is complicated:
dnl
dnl * FreeBSD supports pthread_set_name_np in <pthread_np.h>
+dnl and (if not _POSIX_SOURCE) pthread_setname_np() in <pthread.h>
+dnl because of the conditional visibility, we prefer the former.
dnl * glibc supports pthread_setname_np
dnl * Darwin supports pthread_setname_np but does not take a
dnl pthread_t argument.
@@ -1270,7 +1272,7 @@ AC_LINK_IFELSE([
[[
#include <pthread_np.h>
]],
- [[pthread_setname_np(pthread_self(), "name");]]
+ [[pthread_set_name_np(pthread_self(), "name");]]
)],
[
AC_MSG_RESULT(yes)